Opened 5 years ago

Closed 5 years ago

#2096 closed improve feature (fixed)

Show translation only if English is older

Reported by: shevek Owned by: Tsjoek
Priority: major Milestone: 2.3
Component: BW Internationalization Keywords:
Cc:

Description (last modified by Tsjoek)

Several important texts on the website are shown translated despite the fact that they are outdated.

This should be changed so that the English text is preferred in these cases to ensure up-to-date information for the members.

Related : #2101

Change History (16)

comment:1 Changed 5 years ago by shevek

  • Status changed from new to to_alpha

comment:2 Changed 5 years ago by shevek

  • Status changed from to_alpha to testing

comment:3 Changed 5 years ago by shevek

Updated database to have a field that stores if a change was minor or major. If the change was only minor prefer translation.

Added field to adminword to be able to set this (English only).

Commit: https://gitorious.org/bewelcome/rox/commit/466f07c6eb97651123b30245d0cfe1aa2b0a6d7d

Database changes:

ALTER TABLE  `words` ADD  `change` ENUM(  'Minor',  'Major' ) NULL DEFAULT NULL AFTER  `TranslationPriority` ,
ADD  `deleted` TINYINT( 1 ) NULL DEFAULT NULL AFTER  `change` ;

Note: 'deleted' isn't used yet.

comment:4 Changed 5 years ago by shevek

Small update: Treat a 'NULL' change field as major change.

https://gitorious.org/bewelcome/rox/commit/d8af91ce8bc94f6b1ec5914b8a0a8011a7e62440

comment:5 Changed 5 years ago by shevek

Deployed to alpha.

comment:6 Changed 5 years ago by Tsjoek

  • Status changed from testing to needs_work

After consulting shevek: It seems more suitable to me to make a timestamp column with the actual moment of the last major update in English. That way one or more minor updates after a major update will not confuse things.

comment:7 Changed 5 years ago by Tsjoek

  • Owner changed from shevek to Tsjoek
  • Status changed from needs_work to assigned

comment:8 Changed 5 years ago by Tsjoek

  • Component changed from unknown to BW Internationalization
  • Description modified (diff)
  • Type changed from unknown to improve feature

comment:9 Changed 5 years ago by shevek

  • Milestone changed from 2.2 to 2.3

Moving to 2.3.

comment:10 Changed 5 years ago by Tsjoek

executed as in comment 6. See #2107 for db-updates

comment:11 Changed 5 years ago by shevek

  • Status changed from assigned to to_alpha

comment:12 Changed 5 years ago by shevek

  • Status changed from to_alpha to testing

Deployed to alpha.

comment:13 Changed 5 years ago by crumbking

How to test here? Example needed.

comment:14 Changed 5 years ago by Tsjoek

Because it was codingwise convenient, wordcodes for the errormessages are already created, but they don't serve any purpose yet. You could use them to do some testing.
Examples:
AdminWordErrorNeedOneSearchTerm
AdminWordErrorCodeEmpty
AdminWordErrorDescriptionEmpty

They're currently set to DNT, so you need admin rights to unset that. Please after testing set them back to DNT as a 'major change' to invalidate any translations you made. (But they will be used as soon as we move to a translatable interface).

comment:15 Changed 5 years ago by shevek

A lot of FAQ answers on French show up as untranslated at the moment. They don't do that on www. Maybe that's enough of an example?

comment:16 Changed 5 years ago by sitatara

  • Resolution set to fixed
  • Status changed from testing to closed

Just confirmed this with the textual change on the donation page. Fantastic improvement to make sure website texts are up-to-date! Thanks!

Note: See TracTickets for help on using tickets.