Opened 10 years ago

Closed 9 years ago

#216 closed bug (fixed)

undefined property: stdClass::$photo

Reported by: philipp Owned by:
Priority: major Milestone: 0.1.4
Component: BW Profile Keywords:
Cc:

Description

On (some) profile pages (eg. ieva) you get

Notice: Undefined property: stdClass::$photo in /home/bwrox/bwrox.production/htdocs/bw/layout/member.php on line 91

Change History (4)

comment:1 Changed 10 years ago by micha

  • follow_up changed from none to test
  • Milestone changed from 0.1.1-outreach-bugfixing to 0.1.2 - more improvements & bugfixing

Can this error still be confirmed after the last release?

comment:3 Changed 9 years ago by midsch

  • follow_up changed from test to review code

I found another on alpha/production (torgal67's comments: http://alpha.bewelcome.org/bw/viewcomments.php?cid=69 in comment from speedsparrow)

Notice: Undefined property: stdClass::$photo in /home/bwrox/alpha.bewelcome.org/htdocs/bw/layout/viewcomments.php on line 95

It's hard to test on test because of the lacking data. Here is no fix mentioned that could be moved and tested to alpha, so I set it back to review code.

comment:4 Changed 9 years ago by jeanyves

  • freq_reported set to 1
  • Resolution set to fixed
  • show_on_bw set to 0
  • Status changed from new to closed

The problem was caused by justee profile which has no picture. this case was not tested when retrieving the pictures for special relation.

It is fixed now

Note: See TracTickets for help on using tickets.