Opened 5 years ago

Closed 4 years ago

#2168 closed improve feature (fixed)

Remove world visibility (part 2)

Reported by: shevek Owned by:
Priority: major Milestone: 2.6
Component: BW Forum Keywords:
Cc:

Description (last modified by shevek)

Update the UI as the drop down for visibility doesn't make sense anymore in the BW forum.

Check if the groups form for posts should be/can be updated as well.


Related ticket: #2167

Change History (20)

comment:1 Changed 5 years ago by shevek

  • Milestone changed from unassigned to 2.5

comment:2 Changed 5 years ago by shevek

  • Status changed from new to to_alpha

comment:3 Changed 5 years ago by shevek

  • Status changed from to_alpha to testing

Deployed to alpha.

comment:4 Changed 5 years ago by shevek

  • Status changed from testing to needs_work

If you start a thread in a group with (group only) and edit it afterwards the visibility jumps to members only.

While editing a thread or post the default value should be the same as before the edit.

comment:5 Changed 5 years ago by shevek

  • Description modified (diff)

comment:7 Changed 5 years ago by crumbking

I wanted to edit my testing milestone 2.5 thread. (to only update the 2.4->2.5) There was the ForumVisibilityGroupOnlyThread? not selected. I submitted and ended up on a screen: You're either not a member of this group or you need to be logged in to see this thread.

Fun part is if I visit http://alpha.bewelcome.org/groups/62/forum/s11354 I see now: I submitted and ended up on a screen: You're either not a member of this group or you need to be logged in to see this thread.

Means I'm part of the group but do not see my own thread anymore ;-)

comment:8 Changed 5 years ago by shevek

You should be able to see your thread again. Additionally I fixed the root cause :-)

comment:9 Changed 5 years ago by crumbking

Within a Forum Thread the visibility Could be hidden in the forms and Could also be removed in the posts.

comment:10 Changed 5 years ago by shevek

Unfortunately I don't think it is as easy. 1st we have the legacy of different visibilities, dropping the display would give the impression that all posts are only visible to members. Second having different layout of the forms might confuse more than it helps (that's actually why I brought it back after first removing it myself).

comment:11 Changed 5 years ago by crumbking

  • Status changed from needs_work to to_alpha

Okay let's do it without the UI changes.

comment:12 Changed 5 years ago by crumbking

  • Status changed from to_alpha to testing

comment:13 Changed 5 years ago by crumbking

  • Resolution set to fixed
  • Status changed from testing to closed

tested a bit on alpha

comment:14 Changed 4 years ago by shevek

  • Milestone changed from 2.5 to 2.6
  • Resolution fixed deleted
  • Status changed from closed to reopened

Testing a bit obviously missed the problem with a missing post visibility in case the thread poster left the option to move between members and group only.

Moved ticket to 2.6 and committed a fix:

https://gitorious.org/bewelcome/rox/commit/9f14a1c989cf98cdc266de19bd59242aaa80865e

comment:15 Changed 4 years ago by shevek

  • Status changed from reopened to local_testing

comment:16 Changed 4 years ago by shevek

  • Status changed from local_testing to to_alpha

comment:17 Changed 4 years ago by shevek

  • Status changed from to_alpha to testing

comment:18 Changed 4 years ago by shevek

  • Status changed from testing to to_beta

comment:19 Changed 4 years ago by shevek

  • Status changed from to_beta to testing

comment:20 Changed 4 years ago by crumbking

  • Resolution set to fixed
  • Status changed from testing to closed

Tested a bit.Seems to work.

Note: See TracTickets for help on using tickets.