Opened 5 years ago

Closed 5 years ago

#2175 closed bug (fixed)

Obsolete javascript brokes map search

Reported by: toub Owned by:
Priority: major Milestone: 2.4
Component: unknown Keywords: 2.4.1, hotfix
Cc:

Description

I had a Javascript blocking error in production (with map search broken as consequence).

Refreshing the cache (F5) solved the problem, what means that some files versions were not updated in main.js

Change History (5)

comment:1 Changed 5 years ago by toub

  • Status changed from new to local_testing

comment:2 Changed 5 years ago by toub

I fixed it by upgrading the version number of all our JS files (as it is really hard to reproduce).

There will be a very light impact in loading time at the very first request of every users.

A long term solution will be to replace our JS dependency mechanism. We could have a grunt/gulp job compressing the files and automatically adding a version number.

comment:3 Changed 5 years ago by crumbking

  • Keywords 2.4.1 hotfix added
  • Milestone changed from unassigned to 2.4
  • Status changed from local_testing to to_alpha
  • Type changed from unknown to bug

hotfix

comment:4 Changed 5 years ago by crumbking

  • Status changed from to_alpha to testing

comment:5 Changed 5 years ago by crumbking

  • Resolution set to fixed
  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.