Opened 10 years ago

Closed 10 years ago

#218 closed bug (worksforme)

images (thumbnails) not displayed

Reported by: philipp Owned by:
Priority: blocker Milestone: 0.1.2-outreach-bugfixing
Component: BW General Keywords: thumbs
Cc:

Description

when visiting whoisonline you sometimes get this warning instead of the member thumbnail. Don't know yet when exactly.

Warning: imagejpeg() [function.imagejpeg]: Unable to open '/home/bwrox/data/images/thumbs/michalknitl_1197024268.square.100x100.jpg' for writing: Permission denied in /home/bwrox/bwrox.production/htdocs/bw/lib/FunctionsTools.php on line 957
Profile

Change History (9)

comment:1 Changed 10 years ago by philipp

this problem themes to be rather image dependant than page dependant. The same image is broken on the profile page while others work fine on profile and whoisonline

comment:2 Changed 10 years ago by philipp

  • Summary changed from whoisonline member thumbnail sometimes broken to images (thumbnails) not displayed

this seems to happen for newly uploaded images as well (or only for them?)

comment form thorgal (in BW forum)

here is the first bug i encountered, using Mozilla/5.0 (Windows; U; Windows NT 5.1; nl; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

  • I uploaded a new profile picture (size about 220 kb), but when i try to look at it on my account, it fails to upload on my profile page and i get the following error :

Warning: imagejpeg() [function.imagejpeg]: Unable to open '/home/bwrox/data/imagesthumbs/thorgal67_1197039379.square.80x80.jpg' for writing: Permission denied in /home/bwrox/bwrox.production/htdocs/bw/lib/FunctionsTools.php on line 957

comment:3 follow-up: Changed 10 years ago by jeanyves

  • Keywords thumbs added
  • Owner set to jeanyves
  • Priority changed from major to blocker

This is critical/blocker because when someone update a picture he then has a critical message on his profile

The problem is that there is a mess with the size of thumb, some are 100x100 others are 80x80.
The way to solve this properly is to have a $_SYSHCVOL[thumb_width] and a $_SYSHCVOL[thumb_height] used instead of hardcoded values

I am preparing it but I still have problems making $_SYSHCVOL[] data visible inside rox module (and I didn't forget the global $_SYSHCVOL)

I need help for solving the $_SYSHCVOL[] issue :

  • where to include the config.php file for all rox code to see it
  • how to make a global visible inside a class method

nota : hardcoded values, different values, redudant code ... please understand that the priority is not QA , we have concrete things to solve first !

comment:4 in reply to: ↑ 3 Changed 10 years ago by jeanyves

Replying to jeanyves:

This is critical/blocker because when someone update a picture he then has a critical message on his profile

The problem is that there is a mess with the size of thumb, some are 100x100 others are 80x80.
The way to solve this properly is to have a $_SYSHCVOL[thumb_width] and a $_SYSHCVOL[thumb_height] used instead of hardcoded values

I am preparing it but I still have problems making $_SYSHCVOL[] data visible inside rox module (and I didn't forget the global $_SYSHCVOL)

I need help for solving the $_SYSHCVOL[] issue :

  • where to include the config.php file for all rox code to see it
  • how to make a global visible inside a class method

nota : hardcoded values, different values, redudant code ... please understand that the priority is not QA , we have concrete things to solve first !

In /home/bwrox/bwrox.production/htdocs/bw/lib/FunctionsTools.php on line 957, I have added online an @ to prevent error warning to be displayed :

@imagejpeg($thumb,$thumbfile,$quality);

This doesn't solve the problem but make the layout less messy

comment:5 Changed 10 years ago by jeanyves

Update : accoding to various diagnostics I attempt, the old gethumbs in FunctiunTools?.php is not able to create new thumbs if they are missing.

I tried various things and gave up.

This is still a blocker problem

comment:6 Changed 10 years ago by steinwinde

  • Owner changed from jeanyves to steinwinde
  • Status changed from new to assigned

comment:7 follow-up: Changed 10 years ago by steinwinde

  • Owner steinwinde deleted
  • Status changed from assigned to new

Hannu advised me of the way images are handled on production, see this e-mail:

Subject: Re: [BW-dev-discussion] http://bull.bewelcome.org ready for testing
Date: Wed, 5 Dec 2007 12:58:47 +0100
From: Tobias Brox <tobixen@gmail.com>
Reply-To: BeWelcome Developers Team <bw-dev-discussion@bewelcome.org>
To: BeWelcome Developers Team <bw-dev-discussion@bewelcome.org>
References: [...]
[Michael Dettbarn]
> If you compare those user-pics in /main on BULL with ALPHA, then you
> will see that on alpha the pictures exist locally and on bull, they
> don't (!).

The images are hooked up through smbfs, so the application should be
able to access them through the file system.

There's a good chance, that all problems will vanish as soon as we get away from samba mounts. Anybdody here able to do this?

PLEASE KNOW: On production we use a different version of FunctionsTools?.php than the one, which is in trunk and alpha. (Reason has been this ticket 218.) This fact should be corrected.

comment:8 in reply to: ↑ 7 Changed 10 years ago by tobixen

Replying to steinwinde:

There's a good chance, that all problems will vanish as soon as we get away from samba mounts. Anybdody here able to do this?

Fixed, images are now stored locally.

comment:9 Changed 10 years ago by steinwinde

  • Resolution set to worksforme
  • Status changed from new to closed

With r3445 any problems with the pictures should be clearly visible again. But there were no error messages any more. As far as I can see, this problem has been solved by hannu and tobixen - thanks!

Note: See TracTickets for help on using tickets.