Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#22 closed task (fixed)

configure the fields, values and options for the ticket form

Reported by: philipp Owned by: tobixen
Priority: critical Milestone:
Component: unknown Keywords:
Cc:

Description (last modified by tobixen)

  • Fix "easy" checkbox
  • Add "obsoleted" to the resolution box
  • Fix some kind of ticket status for bugs (assigned -> confirmed -> to be verified -> resolved as verified)

Change History (18)

comment:1 Changed 10 years ago by philipp

  • Owner somebody deleted

comment:2 Changed 10 years ago by anonymous

types:

  • defect = bug
  • enhancement = feature
  • task = ?

components:

components to add:

  • BV Wiki
  • BV Forum
  • BV Flyspray
  • BV trac
  • BW general
  • BW search
  • BW mail
  • BW layout
  • BW profile
  • BW forum
  • BW groups

comment:3 Changed 10 years ago by bw_trac@…

Missing field: relations, sth. like:

  • ticket#22 depends on ticket#24
  • ticket#22 is duplicate of ticket#24
  • ticket#22 is related to ticket#24

comment:4 Changed 10 years ago by midsch

  • Cc bw_trac@… added

comment:5 Changed 10 years ago by midsch

Missing field/checkbox: "keep me updated" (info mail for every change, could be done by CC-field, but I'd use it for involved developers only)

comment:6 Changed 10 years ago by midsch

Points from Tobias / Philip can be found here: bw-dev-list

comment:7 follow-up: Changed 10 years ago by midsch

types existing:

  • defect = bug
  • enhancement = feature
  • task = job?

types missing:

  • update feature = or just reopen a feature?
  • unknown

(Database and layout is part of component, not a type)

resolve as - existing

  • new
  • fixed
  • invalid
  • wont fix
  • duplicate
  • works for me
  • reopen

we have also an assign field, but no status about it, at the same place we'd need:

  • assigned
  • confirmed
  • to be tested (fixed but needs test, after testing -> verified or reopen / reassign)
  • verified (tested & works, after commiting the fix -> closed)

comment:8 Changed 10 years ago by midsch

resolve as - missing:

  • obsolete (nomore fix needed, because of other repairs, deactivation of the function)

from mailing list:

  • to be tested should be called "to be verified")
  • remove the auto assignements to yj and somebody
  • components to add: - BV Wiki - BV Forum - BV joomla - BV trac - BW general - BW search - BW mail - BW layout - BW profile - BW forum
    • every build (forum, memberssearch, rox, ....)
    • smarty/css (for the template part)
  • grouping of tasks by the build they affect most could make sense to get a fast impression on which part is affected by the task.
  • Tick box "easy"
    • Change Version values to "test, alpha, life, all" with life being default (if text is allowed in this field)

comment:9 Changed 10 years ago by tobixen

  • Owner set to tobixen
  • Status changed from new to assigned

What is "life" version? Maybe it should be "live" or "production"?

I have a feeling that the list above is not final nor authoritative. Someone should sum up the consensus from the discussions on the mailing list. Maybe edit the TracTickets, write the purpose of the different versions, milestones, etc, and write everything that is missing in cursive?

comment:10 Changed 10 years ago by philipp

"life" should of course be "live", "production" would be fine as well

You are right that the list is neither final nor authorative. However I think we could start with this list and then modify where needed. Of course the will be a description of every single option as it has been available for flyspray pretty soon. But we really need the options to be able to move the tickets from flyspray and to close flyspray to avoid confusion.

Thanks for adding.

comment:11 Changed 10 years ago by tobixen

I'm sorry for procrastinating again!

I've fixed the ticket type, please verify and I'll go ahead and do more.

"feature update" confuses me a bit, so I took the liberty to name it "feature_improvement". Not sure if the underscore (_) is needed, though.

comment:12 Changed 10 years ago by philipp

I am fine with your fixes (though putting feature improvement next to feature would be make it perfect)

Thanks

comment:13 in reply to: ↑ 7 ; follow-up: Changed 10 years ago by tobixen

I didn't figure out yet how to change the "resolve as" or "assign" fields. I can change the values for priority, severity (?), version and milestone through the trac-admin interface. I know there has been some discussion about those fields, but ... what should I set those to?

comment:14 in reply to: ↑ 13 Changed 10 years ago by tobixen

Version field fixed now

comment:15 Changed 10 years ago by tobixen

  • Description modified (diff)
  • severity set to normal

I think I've fixed all in this ticket that I easily could fix through the trac-admin command.

comment:16 Changed 10 years ago by philipp

thanks, looks fine for me
One minor thing: would be good to rename version "beta" to "alpha" as we only have the test, alpha, and production

Besides this I would opt to close this ticked and create a new one for any future changes

comment:17 Changed 10 years ago by philipp

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:19 Changed 10 years ago by midsch

  • Cc bw_trac@… removed
Note: See TracTickets for help on using tickets.