Opened 3 years ago

Last modified 3 years ago

#2210 reopened bug

country pages - wrong login to see more message

Reported by: crumbking Owned by: Tsjoek
Priority: minor Milestone: unassigned
Component: BW Places Keywords:
Cc:

Description

If you are logged in and surf country pages in /places like

http://www.bewelcome.org/places/Germany/DE/

you get the message to login which is wrong

Change History (15)

comment:1 Changed 3 years ago by crumbking

  • Summary changed from country pages to country pages - wrong login to see more message

comment:2 Changed 3 years ago by crumbking

  • Component changed from BW Search to BW Places

comment:3 Changed 3 years ago by Tsjoek

  • Owner set to Tsjoek
  • Status changed from new to assigned

The problem is bigger than just a label: some countries and regions show this loginhint and have a pagination upto 1212. The memberfilter is ok though, the addiditional pages are just empty. Strangely enough there are also countries/regions that seem just fine. It has something to do with counting the members to be displayed. I'll dig into it.

comment:4 Changed 3 years ago by Tsjoek

Some thoughts and funfacts:

  • I can't reproduce the bug locally. It is however easy to reproduce at alpha and www.
  • I cannot find any logical connection between countries/regions that are ok, and those that are not.
  • It seems to me that the numbers mentioned behind the countries have gone down over the past month/2 months. (Slovenia was around 100, testdb says 101, it's now 86)
  • Members that live in a place that doesn't have a region in geonames are now counted with an empty (read: suppressed notice) regionname. I didn't see that before, I think they were just ignored.
  • I cannot find anything suspicious in the 2.5 tickets that possibly would trigger this.
  • The Czech Republic has a new official English name.

Maybe a recent geonames update has triggered something?

comment:5 Changed 3 years ago by crumbking

We did a massmail login reminder session which sets some profiles to another status if they do not login. Maybe that's the cause of the drop down of the numbers?

comment:6 Changed 3 years ago by Tsjoek

Yes the dropdown was because of the reminder, and because we had OutOfRemind? profiles before this should be unrelated.

In the meanwhile I finally found a case locally, but in this case on www, the pagination was alright but the incorrect login hint shows up:
http://www.bewelcome.org/places/Argentina/AR/Provincia%20de%20Buenos%20Aires/01

This one seems to be caused because we have members (n=133 in the testdb) that have an idCity which is not a city but a region or a country. One of them is for example directly living in the Federal Republic of Germany.

Query to find them:

select * from members 
join geonames on members.idcity = geonames.geonameid
where fclass='A'

I've deleted those members locally, and the login hint disappeared. But somehow I think this is only part of the problem, because:

  • Why haven't we noticed this before?
  • What's wrong with the pagination?

comment:8 Changed 3 years ago by Tsjoek

It is memberCount that defines the total number of pages, somehow that ends up above 24000. So it seems to miss a filter somewhere, but as long as it doesn't appear locally, it's certainly something outside the codebase I'd say.
And as long as I can't see it locally it's pretty difficult to track.

I find the SQL_CALC_FOUND_ROWS a bit suspicious, but can't see anything wrong in it.
Another thing that has changed recently is the server setup together with php and possibly mysql version, but again: how would that influence this?

For now I stay with geonames as my first suspect. I'll ask shevek for a fresh dump of that data.

What is special about the Burkina Faso case?

comment:9 Changed 3 years ago by Tsjoek

Update:
Miraculously the remaining part of the issue seems to be currently resolved on the server. The problem has not been recreated locally. Database seems to be exactly the same. Resetting the query cache has been tried, without effect.
The already cleared up part of the issue (see comment 6) still exists, but is fixable.

However the problem seems to have moved to groups now:
http://www.bewelcome.org/groups/77

Also this one I have not been able to recreate locally so far.

comment:10 Changed 3 years ago by Tsjoek

This is the Berlin-virus! Not less than 10 Berlin related groups are affected. I couldn't find any group that is not related to Berlin that has it. :-s

Just when I thought this ticket couldn't get weirder. Where is that candid camera? ;-)

comment:11 Changed 3 years ago by crumbking

  • Status changed from assigned to to_alpha

I suggest we close this one. As the problem seems to be solved for places. Lets open for the group problem a new ticket. Btw I could only reproduce the problem on http://www.bewelcome.org/groups/77. Not on other Berlin related groups.

comment:12 Changed 3 years ago by crumbking

  • Status changed from to_alpha to testing

comment:13 Changed 3 years ago by crumbking

  • Resolution set to fixed
  • Status changed from testing to closed

comment:14 Changed 3 years ago by crumbking

Related: #2221

Last edited 3 years ago by crumbking (previous) (diff)

comment:15 Changed 3 years ago by Tsjoek

  • Milestone changed from 2.6 to unassigned
  • Resolution fixed deleted
  • Status changed from closed to reopened

I'm reopening this ticket, because it still contains the unresolved issue for places that contain members who live in something that is not a city, but unassign it from 2.6. I'm still hoping that we figure out the whole issue before starting to fix something.

Note: See TracTickets for help on using tickets.