Opened 10 years ago

Closed 10 years ago

#224 closed bug (worksforme)

bad display of comments (system error messages)

Reported by: ocal5 Owned by:
Priority: major Milestone:
Component: BW Layout Keywords: comments display
Cc:

Description

Thanks to Kiwiflave

2 undefined lines are displayed at the top of the page :

Notice: Undefined property: stdClass::$IdContact in /home/bwrox/bwrox.production/htdocs/bw/layout/viewcomments.php on line 48

Notice: Undefined property: stdClass::$IdRelation in /home/bwrox/bwrox.production/htdocs/bw/layout/viewcomments.php on line 57"

URL = http://www.bewelcome.org/bw/viewcomments.php

... and I have try before log-in... quite ugly !

#0 debug( query problem with select SQL_CACHE * from memberspublicprofiles where memberspublicprofiles.IdMember= mysql_error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 ) called at [/home/bwrox/bwrox.production/htdocs/bw/lib/bwdb.php:123] #1 sql_query(select SQL_CACHE * from memberspublicprofiles where memberspublicprofiles.IdMember=) called at [/home/bwrox/bwrox.production/htdocs/bw/lib/bwdb.php:135] #2 LoadRow(select SQL_CACHE * from memberspublicprofiles where memberspublicprofiles.IdMember=) called at [/home/bwrox/bwrox.production/htdocs/bw/lib/FunctionsTools.php:760] #3 IsPublic() called at [/home/bwrox/bwrox.production/htdocs/bw/viewcomments.php:40] query problem with select SQL_CACHE * from memberspublicprofiles where memberspublicprofiles.IdMember= mysql_error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 
query problem 82.247.111.71 December 7, 2007, 8:08 pm

... so, good luck !

Change History (1)

comment:1 Changed 10 years ago by steinwinde

  • Resolution set to worksforme
  • Status changed from new to closed

In regard to the two "Notice: Undefined..." lines in the page, this ticket is a duplicate of #187 (fixed in repository, the code is not yet on www.bewelcome.org).

In regard to the message "#0 debug( query problem...": Where did you find the link to the page http://www.bewelcome.org/bw/viewcomments.php ? The problem is the link, not the error messages on the page you get. The link needs additional parameters to lead to a reasonable page. In case you just manipulated a link, this is hardly a bug, because you easily can produce plenty of alleged bugs by manipulating (or cutting) parameters in links you find. A sound link would look like this:

http://www.bewelcome.org/bw/viewcomments.php?cid=227

(Being 227 the ID of a user, who agreed, that his profile is publicly visible.)

Note: See TracTickets for help on using tickets.