Opened 9 years ago

Closed 9 years ago

#258 closed bug (fixed)

update TinyMCE, the WYSIWYG engine in the BW forum

Reported by: lemon-head Owned by:
Priority: major Milestone: 0.1.2.1
Component: BW Forum Keywords: TinyMCE, wysiwyg
Cc:

Description

As far as I remember, the wysiwyg engine in our bw forum is a third-party software.

As a first step to get to a useful and reliable posting interface will be to make an update of the wysiwyg engine. If this doesn't help, we can still try to find something better.

The job:

  1. find out the brand of the wysiwyg engine
  2. find their website
  3. update
  4. test...

Yes that's it.

Change History (16)

comment:1 Changed 9 years ago by midsch

Forum software SMF 1.1.3 - http://www.simplemachines.org/ (version 1.1.4 available)

According to http://docs.simplemachines.org/index.php?P=e7951e99d11f95f7c7990a280d8fd065&board=22.0;sort=subject the
WYSIWYG-part is part of SMF, but using BBCode like a lot of other forums, i. e. http://en.wikipedia.org/wiki/BBCode

comment:2 Changed 9 years ago by micha

I don't understand why the ticket status is "test". Does it mean you updated the WYSIWYG-part in the BW-Forum? I have the feeling it is quite different but I'm not so sure...

comment:3 Changed 9 years ago by lemon-head

  • follow_up changed from test to none

sorry boys :)

  • it's not about the smf bv forum, but the BeWelcome forum
  • the wysiwyg engine is called TinyMCE
  • the status was "test" because I did not understand the purpose of this setting when I created the ticket :)

comment:4 Changed 9 years ago by lemon-head

  • Summary changed from update the WYSIWYG engine in the BW forum to update TinyMCE, the WYSIWYG engine in the BW forum

comment:5 Changed 9 years ago by lemon-head

  • Keywords TinyMCE added

comment:6 Changed 9 years ago by lemon-head

  • Milestone changed from 0.1.4 to 0.1.2.1 release with MOD_words + MOD_layoutbits

Yes, this will happily go in the next release :)

comment:7 Changed 9 years ago by lemon-head

  • follow_up changed from none to test

Maybe this could work with 1 changeset as well, but I'm not so familiar with svn, and don't want to leave dead bodies around. Therefore:

  • [3824] - remove (rename) the old version (move to htdocs/script/tiny_mce_old for backup)
  • [3825] - upload new version in htdocs/script/tiny_mce
  • [3826] - restore and improve configuration (see #358) of TinyMCE in editcreateform.php

comment:8 Changed 9 years ago by lemon-head

Forgot to say: New version is TinyMCE 2.1.3 stable (the latest stable release)

comment:9 follow-up: Changed 9 years ago by globetrotter_tt

The numbered list, and text align are not working. http://test.bewelcome.org/forums/s26?sidTB=nKfQ9t1J5safBp1b22gHKN,n5jb

tested on Opera 9.25 (Ubuntu 7.10)

comment:10 in reply to: ↑ 9 Changed 9 years ago by globetrotter_tt

  • Resolution set to fixed
  • Status changed from new to closed

Replying to globetrotter_tt:

The numbered list, and text align are not working. http://test.bewelcome.org/forums/s26?sidTB=nKfQ9t1J5safBp1b22gHKN,n5jb

tested on Opera 9.25 (Ubuntu 7.10)

fixed with #3844

comment:11 Changed 9 years ago by globetrotter_tt

  • follow_up changed from test to move to alpha

comment:12 Changed 9 years ago by lemon-head

  • Priority changed from major to blocker
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Type changed from improve feature to bug

This ticket has been closed before it was finished. Damn!!! We still have the old TinyMCE on alpha and production!

For me this means, I get a plain html textarea.

It was ignored, because the ticket did no longer show up in the milestone. Still, it is strange that noone noticed this problem on alpha (I surfed a lot with javascript disabled)

comment:13 Changed 9 years ago by matrixpoint

  • follow_up changed from move to alpha to test on alpha

TinyMCE moved to alpha in r3980, r3981.

comment:14 Changed 9 years ago by matrixpoint

editcreateform (r3826) moved to alpha in r3983

comment:15 Changed 9 years ago by matrixpoint

  • follow_up changed from test on alpha to none

A streamlined, but working version is now on production (r3999).

This needs more work if we are going to use some of the advanced features, but the few members of the community that responded to a forum post about the features generally didn't think the advanced features are very important. So, I don't know if we need to keep this open, but at least I'll remove the follow up for now.

comment:16 Changed 9 years ago by lemon-head

  • freq_reported set to 1
  • Priority changed from blocker to major
  • Resolution set to fixed
  • show_on_bw set to 0
  • Status changed from reopened to closed

Ok, I think we can close this, and reopen if we get complaints. If we decide to further change the configuration, we can make a new ticket for it.

Note: See TracTickets for help on using tickets.