Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#276 closed bug (fixed)

Image upload doesn't work on localhost

Reported by: matrixpoint Owned by: matrixpoint
Priority: major Milestone: 0.1.2-outreach-bugfixing
Component: BW General Keywords:
Cc:

Description

Testing showed that the $_POST and $_FILES variables never make it to the form action page.

Probably caused by the elaborate Javascript uploader, which tries to load the result into an iframe and displays a waiting message during upload.

Change History (11)

comment:1 Changed 10 years ago by matrixpoint

  • follow_up changed from none to test

Fixed in r3568 by omitting the javascript uploader code.

The lost waiting message could be restored later if desired using a simpler method.

comment:2 Changed 10 years ago by matrixpoint

  • follow_up changed from test to move to alpha

Tested on test (trunk).

comment:3 Changed 10 years ago by matrixpoint

  • follow_up changed from move to alpha to test on alpha

Moved to alpha in r3570.

comment:4 follow-up: Changed 10 years ago by matrixpoint

Tested on alpha. Looks good.

We need a warning about maximum picture size for uploading (about 2 MB). Right now, there is no warning or error message for images that exceed the limit. I'll open another ticket.

comment:5 in reply to: ↑ 4 Changed 10 years ago by matrixpoint

Replying to matrixpoint:

We need a warning about maximum picture size for uploading (about 2 MB). Right now, there is no warning or error message for images that exceed the limit. I'll open another ticket.

Ticket #277 opened.

comment:6 follow-ups: Changed 10 years ago by micha

  • follow_up changed from test on alpha to release

yes, seems to work. No problems uploading on localhost. Can be moved to production.

In the other hand I don't really understand this ticket. Image-uploading on localhost also worked before this fix for me. So maybe you should try to get it working with the javascript thing too. In terms of usability it's a good thing as it visually shows the ongoing activity. I would wish the same for the search, actually. Maybe this would be easy to implement? Maybe without the iframe?

comment:7 in reply to: ↑ 6 Changed 10 years ago by matrixpoint

Replying to micha:

In the other hand I don't really understand this ticket. Image-uploading on localhost also worked before this fix for me. So maybe you should try to get it working with the javascript thing too. In terms of usability it's a good thing as it visually shows the ongoing activity. I would wish the same for the search, actually. Maybe this would be easy to implement? Maybe without the iframe?

I didn't actually figure out the reason for the failure on my localhost. The code was complex (unnecessarily so, I thought) -- we can accomplish what we need to easily without it. I could have written a very quick and simple javascript status indicator for use during uploading (which can be slow). But I lumped it in with the warning/error reporting issues in ticket #277, which are non-trivial. Although these issues are all important, they are non-critical and can be addressed in the next release.

comment:8 in reply to: ↑ 6 Changed 10 years ago by matrixpoint

Replying to micha:

yes, seems to work. No problems uploading on localhost. Can be moved to production.

Must wait for #113, since some of the same files are involved.

comment:9 Changed 10 years ago by matrixpoint

Moved to production in r3587.

comment:10 Changed 10 years ago by matrixpoint

  • Resolution set to fixed
  • Status changed from new to closed

comment:11 Changed 10 years ago by matrixpoint

  • follow_up changed from release to none
Note: See TracTickets for help on using tickets.