Opened 10 years ago

Closed 6 years ago

Last modified 6 years ago

#281 closed bug (fixed)

Show error message, when cookies are blocked at login

Reported by: midsch Owned by: steinwinde
Priority: critical Milestone: 0.5.5 - bugfixing
Component: BW General Keywords: login error message
Cc: midsch

Description

If someone tries to login at BW who blocks cookies in his browser, the startpage with empty login fields is shown again and again. Would be nicer to show the user an error message like "For login you need to enable cookies in your browser" Preferably with links to http://test.bewelcome.org/privacy where a "cookie"-section is needed anyway and to a short howto-enable-cookies.

Maybe here are cookies (and a hint when blocked) necessary as well: http://test.bewelcome.org/bw/signup.php

Change History (17)

comment:1 Changed 10 years ago by feuerdaemon

  • freq_reported set to 2
  • Priority changed from major to critical
  • show_on_bw set to 0
  • Type changed from developer task to volunteer attention

It's really hard, to find out why you can't login, without any information. Ticket #456 is one bad side-effect. I set this ticket priority up to "critical".

comment:2 Changed 10 years ago by feuerdaemon

  • Milestone changed from unassigned to BigPicture

comment:3 Changed 10 years ago by philipp

  • Type changed from volunteer attention to bug

comment:4 Changed 10 years ago by philipp

  • Milestone changed from BigPicture to unassigned

Milestone BigPicture? deleted

comment:5 Changed 6 years ago by steinwinde

  • Owner set to steinwinde
  • Status changed from new to accepted

comment:6 Changed 6 years ago by steinwinde

I'm going to fix a tiny other bug in the same context: There is already code for users that try to log on without providing their password. However this code is never called. I change the if-statement in a way a specific error message is displayed.

comment:7 Changed 6 years ago by steinwinde

  • Status changed from accepted to assigned

comment:8 Changed 6 years ago by planetcruiser

  • Milestone changed from unassigned to 0.5.5 - bugfixing

comment:9 Changed 6 years ago by steinwinde

  • follow_up changed from none to test on alpha
  • Resolution set to fixed
  • Status changed from assigned to closed

comment:10 Changed 6 years ago by planetcruiser

  • Resolution fixed deleted
  • Status changed from closed to reopened

i get "Please enable cookies in your browser." every time i enter the start page after cookie timeout, although i have cookies activated. using a "private browsing session" has the same result.

i think the cookie check is too simple..

comment:11 Changed 6 years ago by globetrotter_tt

i can confirm this, tested with all common browsers.

comment:12 Changed 6 years ago by planetcruiser

steinwinde: i'd like to release this milestone tomorrow. do you think we can make this fly until then? :)

do you receive these notifications?

comment:13 Changed 6 years ago by steinwinde

I've replaced the PHP check by a trivial Javascript check. This obviously assumes that Javascript is enabled - otherwise it doesn't work.

A PHP based check is apparantly difficult with the current framework. PT code makes the page redirect in case the login form is submitted without cookies. Doing this PT tries to submit anything apart from its own TB session ID (which appears as GET parameter as part of the URL) as cookies. Any error message (including "cookie disabled" warnings) are lost between LoginController?.loginCallback and LoginFormWidget?.render . Therefore it is impossible to distinguish between a first request in a session (where necessarily no cookies are available) and an error due to disabled cookies.

comment:14 Changed 6 years ago by steinwinde

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:15 Changed 6 years ago by globetrotter_tt

Maybe it would be good if the error message could be translated.

comment:16 Changed 6 years ago by crumbking

seems to work I tested with chrome. The error message shows up if I disable cookies.

comment:17 Changed 6 years ago by midsch

Works also with Firefox 8.0 on Kubuntu 64bit. (Although for me the fix is pretty useless as I block cookies _and_ scripts in my default setting.)

Note: See TracTickets for help on using tickets.