Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#309 closed bug (fixed)

link : Reply to message in e-mail is "wrong"

Reported by: ocal5 Owned by:
Priority: critical Milestone: 0.1.3
Component: BW Mail Keywords: e-mail reply link old
Cc: jeanyves, tobixen

Description

Hello / Bonjour,

At this moment, when we want to answer from e-mail, the link is looking like :

http://old.bewelcome.org/contactmember.php?action=reply&cid=abcdef&iMes=XXXX

I think that it should be :

http://bewelcome.org/contactmember.php?action=reply&cid=abcdef&iMes=XXXX

easy, no ? :-)

Thanks !

Change History (11)

comment:1 Changed 9 years ago by philipp

  • Cc jeanyves tobixen added
  • Milestone changed from unassigned to 0.1.3 - more improvements & bugfixing
  • Priority changed from minor to critical

this seems to happen in all messages forwarded to a mailbox. Should be fixed as soon as possbile

comment:2 Changed 9 years ago by lemon-head

  • see htdocs/bw/mailbot.php
  • I think the wrong path is in $_SYSHCVOLSiteName?.
  • could be caused by new single-config-file setup.
  • we had a correct path before Sept 21 (or later)
  • we have the wrong path since Dec 13 (or earlier)
  • it only happens in the reply-link, not in "visit the profile of.." or "check your inbox"

To do now:

  1. correct the path in the reply-link
  2. redirect from old.bewelcome.org/contactmember.php to www.bewelcome.org/contactmember.php. This is necessary, because people already have messages with a wrong link in their inbox, which we cannot change now.


To do later:

  1. What happens if you click the reply-link when you're not logged in? In this case you should not get a nasty error page, but a login page that will automatically redirect you to the reply form after login.

comment:3 Changed 9 years ago by micha

Could you tell me why for god's sake the "old.bewelcome.org" appears in the email anyway? Did somebody change the configuration at some point or does it have to do with ip-addresses or what?

comment:4 Changed 9 years ago by ocal5

some nostalgy from mail server maybe :)

I'm not sure that's really needed to do a "foward" on the old.bewelcome.org/contactmember.php, because it's working perfectly. And it's maybe better to keep this as a normal-working - good old - website ?

Thanks for your very sharp report Lemon-head.

comment:5 Changed 9 years ago by ocal5

Just got a message. Link look like good now... but I fall on :

Notice: Undefined index: IdMember in /home/bwrox/www.bewelcome.org/htdocs/bw/contactmember.php on line 33

Warning: Cannot modify header information - headers already sent by (output started at /home/bwrox/www.bewelcome.org/htdocs/bw/contactmember.php:33) in /home/bwrox/www.bewelcome.org/htdocs/bw/lib/rights.php on line 48

comment:6 Changed 9 years ago by ocal5

Sorry.

I get this message only when I'm not logged-in before. When I log-in and go on url, it displays wonderfully.

And it seems the same on old, is there something different now ?

comment:7 Changed 9 years ago by jeanyves

  • follow_up changed from none to test on alpha

About the old.bewelcome.org/contactmember.php, I have fixed it at the origin on the mailbot which is still running on the goat server (the move of mailbot on bull is till a todo but of less critical urgence)

now reply links are www.bewelcome.org/contactmember.php ... please don't do any redirection '''

I am moving the contactmember.php updated by andreas to Alpha, please someone test it on Alpha (replacing the www... in the reply link by a alpha.... )

(I am goin to test it to)
expected result : if you are not logged on alpha and use the urel of a reply link (with alpha instead of www for this test), you should be prompted for logging in adn then forwarded to contactmember with the appropriated message ready for a reply.

comment:8 Changed 9 years ago by jeanyves

After my first test : I just see that log in is proposed but no forwarding to the reply page occurs.

So there is still a todo, but this version is however better, so if someone confirm this first improvment, please contact me, I think this should go to production quite quiclky (to avoid member who click on reply link to see a error page, thanks andreas !)

comment:9 Changed 9 years ago by philipp

  • follow_up changed from test on alpha to release

I can confirm that you get the login on main page as expected. foward to the expected page is still missing. Better than the current error message - lets put it in production

for the forward, lets check if bringing back the TB login module proposed by micha would do the trick.

comment:10 Changed 9 years ago by philipp

  • Resolution set to fixed
  • Status changed from new to closed

comment:11 Changed 9 years ago by matrixpoint

  • follow_up changed from release to none

Released r3937

Note: See TracTickets for help on using tickets.