Opened 10 years ago

Closed 9 years ago

#312 closed bug (fixed)

Invalid link to change password in profile

Reported by: ocal5 Owned by: JeanYves
Priority: major Milestone: 0.1.4
Component: BW Profile Keywords: password change link
Cc: JeanYves

Description

Thanks a report from BW:runia

There is a link in FAQs who work very well :

http://www.bewelcome.org/user/password

On member profile edit (http://www.bewelcome.org/bw/editmyprofile.php), there is also a link to change password. But this one is different :

http://www.bewelcome.org/bw/changepassword.php?cid=452

But it don't work ! It fowards to home page.

Thanks

Change History (12)

comment:1 Changed 10 years ago by micha

  • Milestone changed from unassigned to 0.1.3 - more improvements & bugfixing
  • Owner set to micha
  • Status changed from new to assigned

comment:2 Changed 10 years ago by micha

  • follow_up changed from none to test

fixed with last commit. Please test once and then move to alpha.

comment:3 Changed 10 years ago by micha

changeset was 3797

comment:4 Changed 10 years ago by midsch

  • follow_up changed from test to review code

The fixed link is indeed fixed and working fine, but I found another one: at http://test.bewelcome.org/bw/faq.php?IdFaq=70 the link http://test.bewelcome.org/bw/changepassword.php is forward to http://test.bewelcome.org/main - if logged in it should lead to http://test.bewelcome.org/user/password, if not logged in warning like "to change your password you must be logged in"

-> set this one back review code.

comment:5 Changed 10 years ago by micha

  • Cc JeanYves added
  • Owner changed from micha to JeanYves
  • Status changed from assigned to new

ok, I fixed the one on test but the wrong link is still present on alpha. I don't have rights to edit the FAQs there. JeanYves?, please change the link in the FAQ "LostPassword?" from "changepassword.php" to "../user/password" !

comment:6 Changed 9 years ago by feuerdaemon

  • freq_reported set to 1
  • show_on_bw set to 0

I've tested it. Works fine.

comment:7 Changed 9 years ago by feuerdaemon

  • follow_up changed from review code to move to alpha

comment:8 Changed 9 years ago by jeanyves

  • follow_up changed from move to alpha to test on alpha

moved to alpha

comment:9 Changed 9 years ago by feuerdaemon

Works also fine in Alpha. Changes should go to Production.

comment:10 Changed 9 years ago by feuerdaemon

  • follow_up changed from test on alpha to release

comment:11 Changed 9 years ago by micha

Let's get rid of these little bugs. JY, could you please change the FAQs or better give me rights to edit them and I do it myself...

comment:12 Changed 9 years ago by micha

  • follow_up changed from release to none
  • Resolution set to fixed
  • Status changed from new to closed

moved to production in rev. 4454

Note: See TracTickets for help on using tickets.