Opened 10 years ago

Closed 9 years ago

#315 closed new feature (fixed)

location selector interface (eg address at signup)

Reported by: philipp Owned by: philipp, micha
Priority: major Milestone: 0.5.2-long
Component: BW Geo Keywords: NewGeo signup location
Cc: steinwinde, lupochen, lemon-head, jaliste

Description (last modified by philipp)

should be used to choose an address, or location throughout the system:

  • at signup
  • adding a hosting location
  • choosing your current location (while traveling)
  • ...

this ticked deals with the interface only, not the logic of retrieving the information (from google, geonames or our own db)

some prototypes have been prepared:

  1. - matrixpoing google 1: http://test.bewelcome.org/playground/signupdemo_google.html
  2. - matrixpoing google 2: http://test.bewelcome.org/playground/signupdemo_google_v2.html
  3. - matrixpoing google 3: http://test.bewelcome.org/playground/signupdemo_google_v3.html
  4. - lemonhead street first: http://test.bewelcome.org/playground/lemon-head/signup_geo_demo.html
  5. - old TB location selector: log in to BW, click on the logo, choose "Settings" from the right column

The requirements are:

  • information to be retrieved (at least at signup)
    • Country
    • City (unambiguous, region if needed)
    • ZIP (if available)
    • Street
    • House number (if available)
  • simple, intuitive interface
  • get detailed, confirmed data that matches our database (or google, ...)
  • make it possible to enter infromation NOT in our databse (to be verified at a later point)
  • must work without JS, but should normally use it
  • should include a map to show selected place (or allow selection by map) BUT MUST work without map (maybe by default)
  • must work in countries where there is no information on street/ZIP level available

should be implemented first in the new signup form

Change History (24)

comment:1 Changed 10 years ago by philipp

  • Component changed from unknown to BW Geo
  • Description modified (diff)

comment:2 Changed 10 years ago by philipp

  • Description modified (diff)

comment:3 Changed 10 years ago by steinwinde

  • Keywords signup location added
  • Owner set to steinwinde
  • Status changed from new to assigned
  • version set to all

comment:4 Changed 10 years ago by lemon-head

The old TB selector doesn't work for me in Opera (both 9.25 and 9.5 beta).

From a usability point of view, it can be an option. Problem: Maps are generally too big to fit between the other controls on the signup page.

comment:5 Changed 10 years ago by steinwinde

  • Owner steinwinde deleted
  • Status changed from assigned to new

comment:6 Changed 10 years ago by jaliste

  • Cc jaliste added
  • freq_reported set to 1
  • show_on_bw set to 0

I like the first prototype... However, How is the confirmation supposed to work?

comment:7 Changed 10 years ago by philipp

  • Milestone changed from 0.1.4 - improving userinterface for members and volunteers and start work on big 0.2 tasks to 0.5.2-long

comment:8 Changed 9 years ago by micha

I really need the playground back to work on this. Meanwhile I start committing the TB-based location-selector in the profile. Will commit that soon

comment:9 Changed 9 years ago by philipp

Do you need playground to show stuff or do you need the files from the playground? The files can be found in svn and: https://www.bewelcome.org/volunteer/playground. Unfortunately many scritpts don't work on my server, so it is not good for demo purposes (we should move the playground back to our server)

comment:10 Changed 9 years ago by micha

  • Owner set to micha
  • Status changed from new to assigned

New stuff in geo-app. See r5660. This affects the signup > #475

comment:11 Changed 9 years ago by micha

  • follow_up changed from none to test

comment:12 Changed 9 years ago by philipp

  • Owner changed from micha to philipp, micha
  • Status changed from assigned to new

comment:13 Changed 9 years ago by philipp

please do some testing using the signup and / or blog feature on test

comment:14 Changed 9 years ago by micha

I tested both signup and blogs on test.bewelcome.org and had no problems with the geo-selection. Tested on FF 3.0.1 and IE7.

comment:15 Changed 9 years ago by philipp

still missing: provide at least basic mechanism when JS is not available

comment:16 Changed 9 years ago by micha

non-js version added in r6117. Please check and give comments (test at signup on test.bewelcome.org/signup/3)

comment:17 Changed 9 years ago by philipp

comments on the non-js version:

  • seems to be fully functional, great
  • I would recommend to use a real pop up (smaller window, not opening in tab, if this is technically possible nowerdays)
  • maybe one could already use a form for location input on the signup/3 page by putting this form below the normal form and then moving it up in the layout by css or maybe by putting the location selection in general as the first item and street bleow. This would allow to use a separate form in non js verison on the same page and then a popup for the result. I think having the entry field already in the signup page helps to make it obvious that you are supposed to enter something
  • if possible it would be cool to atuomatically close the popup / window (if I remember correctly there was some standard html to do this, no?) and to reload the signup/3 page to already show the selected location (this could be done by loading signup/3 to the parent window from the location selctor)
  • we could use static google maps as replacement for normal google maps in non js signup

anyways - all this would only increase usability - functinality is perfect

comment:18 Changed 9 years ago by lemon-head

  • Cc lemon-head added; lemonhead removed

comment:19 Changed 9 years ago by philipp

absolutely great work!

lets give it a last thorough test and collect what is need before it can go online:

  • the signup itself seems to be pretty much done
  • the var_dump() on signup/4 very end of the page needs to be removed
  • views for cities and regions tables need to be configured and tested
  • new geo needs to be tested to be sure that it is really working
  • check that mandatory info displayed (*) and required by coded is identical
  • add the geo selction mechanism to updatemandatory (otherwise people can not change their address after geo/signup release)

comment:20 Changed 9 years ago by micha

new version of geo-selection and signup is online since r6119, please test again signup!

comment:21 Changed 9 years ago by micha

  • follow_up changed from test to test on alpha

latest changes in r6212, Opear and IE should work now.

comment:22 Changed 9 years ago by feuerdaemon

works on FF 3.0.3 @ Kubuntu. Tested on alpha
Only at the "Congratulations!-page" I get a Notice:
Notice: Undefined variable: max in /var/www/test.bewelcome.org/build/geo/geo.model.php on line 158

By the way: Login process is not proved against "back and forward"-clicks! It would maybe good, to fetch that to. (?)

Great work so far.

comment:23 Changed 9 years ago by feuerdaemon

Sorry wrong ticket. But anyway the location selector is working with FF 3.0.3 @ Kubuntu

comment:24 Changed 9 years ago by micha

  • Resolution set to fixed
  • Status changed from new to closed

moved to production around r6400 (several commits)

Note: See TracTickets for help on using tickets.