Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#378 closed new feature (fixed)

donation bar

Reported by: philipp Owned by: micha
Priority: major Milestone: 0.2 - community
Component: BW General Keywords: hot
Cc: micha, jeanyves

Description

http://www.bevolunteer.org/forum/index.php?topic=1384.msg10744#msg10744

For communication purpose, we will use a "bar" to show how much money we have reached, in relation with what we have planned to need.

This bar may be vertical or horizontal and will show which rate is reached. It may go from red to green as long as it goes closer the "100%".

The reference amount (to be reached) will, in the first time, be the expected expenses for the year. In the future it could be used for mini-campaigns, with a specific amount.

  • By default the bar will be in the donations page, but during specific campaigns, they may appear in the news, main page or header.

Examples: wikipedia bar

http://www.bevolunteer.org/wiki/Donations_mini-campaigns

Change History (9)

comment:1 Changed 11 years ago by philipp

  • freq_reported set to 1
  • Keywords hot added
  • show_on_bw set to 0

comment:2 Changed 11 years ago by jeanyves

The donation bar is really needed.

IMHO it should show the needs for the next X months + the allready available money.

I think X should be a parameter, (set to 12 when things will run well) but only to 3 to start. This because if we start with 12 we will display a 95% requirement for donation.

I think the following table donation_bar could manage this (with only one record) :

  • donation_bar.updated when the table was updated
  • donation_bar.amount_needed_permonth the amount needed per month (currently 180€)
  • donation_bar.amount_currently_receive_for_X_next_month the currently received amount
  • donation_bar.NbMonthX the width in terms of months for the donation bar
  • donation_bar.LinkDonationPage? a link to teh donation page (because this is going to change)

The following process are needed :

  • a way to display the donation bar and a link to the donation page (total needed will be : amount_needed_permonth*NbMonthX, current value will be amount_currently_receive_for_X_next_month)
  • a way for the treasurer to update manually : amount_needed_permonth, amount_currently_receive_for_X_next_month, NbMonthX (it really can be a rough interface, or just a specifi phpmyadmin acount)
  • a process which each month does a amount_currently_receive_for_X_next_month=amount_currently_receive_for_X_next_month-amount_needed_permonth
  • a process which will automatically increase amount_currently_receive_for_X_next_month with the confirmed values received by paypal

Of course, in addition a clear text will be needed to explain that all the values are rounded approximative values, that it is possible that there is a delay before the value is updated, especially if a manual donation occurs, that the average monthly amount needed is valueof(amount_needed_permonth), that they can be some exception where the annual needed amount will sundenly grow because of some circumstances.

If someone is ready to make the design, we can work on it and I think it can be quicly done.

comment:3 Changed 11 years ago by micha

  • follow_up changed from none to test on alpha
  • Owner set to micha
  • Status changed from new to assigned

I implemented a donation bar in the rox-based donation. It's available for testing at http://alpha.bewelcome.org/donate

One current bug is that the donation-bar shows different values depending on wether the user is logged in or not. This is due to the fact that we hide donations if the user wants us to and we don't have extra DB-tables that keep track of the total donation.

comment:4 Changed 11 years ago by micha

About the proposed database-table:

I would leave out the

  • donation_bar.LinkDonationPage?? a link to teh donation page (because this is going to change)

Not needed in my opinion. We will use /donate and if this is still going to change than we can make a redirect. Imagine storing all current links in our database... Let's not start with this!

About the requests for the donation bar:

  • a way to display the donation bar and a link to the donation page (total needed will be : amount_needed_permonth*NbMonthX, current value will be amount_currently_receive_for_X_next_month)

DONE

  • a way for the treasurer to update manually : amount_needed_permonth, amount_currently_receive_for_X_next_month, NbMonthX (it really can be a rough interface, or just a specifi phpmyadmin acount)

NOT DONE YET

  • a process which each month does a amount_currently_receive_for_X_next_month=amount_currently_receive_for_X_next_month-amount_needed_permonth

? WHAT DOES THAT MEAN ?

  • a process which will automatically increase amount_currently_receive_for_X_next_month with the confirmed values received by paypal

NOT DONE YET.

In general I'm not sure if it makes sense to make all this soo automatic. A lot of these things may change in the future. Maybe we should leave out the whole monthly costs...

comment:5 Changed 11 years ago by midsch

In general I'm not sure if it makes sense to make all this soo automatic. A lot of these things may change in the future. Maybe we should leave out the whole monthly costs...

I agree. Maybe be it's more easy to let the treasurer(s) - I'm talking to you, right? - manually switch the donation bar status? As the treasurer should know the actual status anyway, it's maybe no big deal ...

For normal members it's just important to see an abstract status like red/orange/yellow/light green/dark green (for details you have dig deeper into the information anyway), for BW/BV it could be important to show the status in a more prominent postision (red / alert).

(I suggest it somewhere in the forum: a better status than red (pink? bw-orange?) would be smart. to show we have enough money (for a period of time like 6 month, one year) and don't accept more donations or at least encourage to donate money to other good projects where the situation is bad.)

comment:6 Changed 11 years ago by philipp

  • follow_up changed from test on alpha to none

follow up set to none as this is already in production I leave it open in case we still want to fix / modifay something

comment:7 Changed 11 years ago by micha

  • Milestone changed from 0.1.4 - improving userinterface for members and volunteers and start work on big 0.2 tasks to 0.1.5 - short - xxx

But let's move it to another release then. I want to get the current release done. Those "thisticketstaysheretomarksomething" annoy me more and more :)

comment:8 Changed 11 years ago by philipp

  • Resolution set to fixed
  • Status changed from assigned to closed

ok - closing this, lets open a new one if needed

comment:9 Changed 11 years ago by philipp

  • Milestone changed from 0.1.5 - short - xxx to 0.2 - community

Milestone 0.1.5 - short - xxx deleted

Note: See TracTickets for help on using tickets.