Opened 11 years ago

Closed 11 years ago

Last modified 6 years ago

#392 closed bug (wontfix)

Reply link in "new message" e-mail don't work

Reported by: ocal5 Owned by:
Priority: critical Milestone: Legacy Resolved
Component: BW Mail Keywords: message link e-mail answer
Cc: jeanyves

Description

When getting a new message, link in e-mail is (2008-02-05):

http://old.bewelcome.org/contactmember.php?action=reply&cid=%CID%&iMes=%iMes%

and we get this error message, IF we are not logged-in OLD.bw.org :

Notice: Undefined index: IdMember in /home/bwrox/old.bewelcome.org/htdocs/bw/contactmember.php on line 33

Warning: Cannot modify header information - headers already sent by (output started at /home/bwrox/old.bewelcome.org/htdocs/bw/contactmember.php:33) in /home/bwrox/old.bewelcome.org/htdocs/bw/lib/rights.php on line 48

Before, it was working well, and url was (2008-01-27):

http://www.bewelcome.org/contactmember.php?action=reply&cid=%CID%&iMes=%iMes%

And I have try, with this url, even without being logged-in, we fall on welcome page, who is better than error message ;) So maybe it should be changed to this "previous" url ? Thanks !

Reported thanks to BW:kiwiflave

Change History (3)

comment:1 Changed 11 years ago by lemon-head

  • Cc jeanyves added

See also #309 - Reply to message in e-mail is "wrong"

With the new release, we now have

  • the redirect from message reply page to mainpage if you are not logged in -> which is good (though not perfect).
  • the reply link changed back to old.bewelcome.org -> which is bad.
  • on old.bewelcome.org, we still have the old version which does not make a redirect to mainpage.

I assume the mailbot runs on the wrong branch of bewelcome. How it works?

  • defined in htdocs/bw/mailbot.php
  • gets the $urltoreply from $_SYSHCVOLSiteName?.
  • $_SYSHCVOLSiteName? is defined in inc/confic.inc.php, gets the value from PVars::getObj('env')->baseuri
  • the $envbaseuri? is defined in inc/config.inc.php

For the redirect back to the reply page, after login, see #389. This is yet to be implemented for the MustLogin?() function on old bw part, with special care of the GET parameters.

comment:2 Changed 11 years ago by jeanyves

  • freq_reported set to 1
  • Resolution set to wontfix
  • show_on_bw set to 0
  • Status changed from new to closed

The cause is mailbot still running on GOAT. I close this ticket and open a one (as a reminder) run mailbot.php on BULL (#408) the #369 for must login is still todo

comment:3 Changed 6 years ago by TimLoal

  • Component changed from unknown to BW Mail
  • Milestone changed from unassigned to Legacy Resolved
Note: See TracTickets for help on using tickets.