Opened 10 years ago

Closed 6 years ago

Last modified 5 years ago

#456 closed bug (duplicate)

Login redirect on test.bw and alpha.bw in Firefox and Internet Explorer

Reported by: lemon-head Owned by:
Priority: critical Milestone: Legacy Resolved
Component: BW General Keywords: login, firefox, internet explorer, redirect
Cc:

Description

I can't login to test.bw with Firefox. IE7 does also make problems. Opera works. (which does not mean much, just in this case it works).

I might look into it when I have time.

Change History (14)

comment:1 Changed 10 years ago by feuerdaemon

Logon to http://test.bewelcome.org works fine with FF 2.0.0.12 on Kubuntu, FF 2.0.0.12 on WinXP and MS IE 6.0.2900.2180 on WinXP. (henri and admin).

comment:2 Changed 10 years ago by philipp

same for me FF - 2.0.0.12 on XP and MS IE 6.0 on XP

comment:3 Changed 10 years ago by lemon-head

@philipp: does this mean, the same as me, or the same as 'feuerdaemon' ?

Btw, the problem can be solved by deleting all cookies.

comment:4 Changed 10 years ago by philipp

shit - login is working fine for me

comment:5 Changed 10 years ago by lemon-head

Could be that [4331] did the trick.

(I replaced 'exit' with 'PPHP::PExit()')

comment:6 Changed 10 years ago by philipp

  • Resolution set to worksforme
  • Status changed from new to closed

comment:7 Changed 10 years ago by narnua

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Okay, clearing cookies, cache and authenticated sessions on FF does seem to help. Same happens on live site as well, which might be a bigger problem if the underlying cause isn't fixed.

comment:8 Changed 10 years ago by philipp

could you please specify under wich circumstances the login is broken.

I can't reproduce this bug using:

IE 5, 6 or 7 / FF 2 (both, using old, existing cache/cookies or clean environment (that has never seen bw before)) - test / alpha/ www - various member accounts.

comment:9 Changed 10 years ago by feuerdaemon

  • freq_reported changed from 1 to 2
  • Keywords internet explorer redirect added
  • Summary changed from Login problems on test.bw in Firefox to Login redirect on test.bw and alpha.bw in Firefox and Internet Explorer

Now, I can confirm this bug: It happend on an used system with Windows Xp Home Edition on FF 2.0.0.12. It was the first time ever, the browser surfed to bewelcome.org.
Problem in Summary: You get redireced to the Startpage after a try to login (also with serval logins). If you enter a not valid username or password, you get the message "Login failed."

(If you want to see the summary scroll down)


"bewelcome.org":
Login worked fine

new tab "test.bewelcome.org":
Login don't work - I entered username and password (from serval accounts) an was direced always to the startpage but dind't get logged in. Closing the tab an open a new one didn't work. If I entered a "wrong" username and password, I got the message "Login failed."

new tab "alpha.bewelcome.org":
Same Problem as test.bewelcome.org.


Then I didn't explicitly loged off from bewelcome.org and just closed the FF Application (with all open and not logged off tabs) and open it again. That solved the problem - BUT - I didn't deleted any cookies (and no autodeleting) I prooved that!
(After I closed the FF Application and before I opened a new FF, I tested with a IE 7.0.5730.13 on the same system. Everything seems to work fine. No login problems.)
Now everthing works fine! (After Reboot, deleting cookies)

Then I created a new user on this machine and tested it with this user:
"bewelcome.org":
Login worked fine with FF and IE

new tab "test.bewelcome.org":
Login don't work in IE and FF. (Problems like known before - {I entered username and password (from serval accounts) an was direced always to the startpage but dind't get logged in. Closing the tab an open a new one didn't work.)}

new tab "alpha.bewelcome.org":
Login don't work in IE and FF. (Problems like known before - {...})

Try to solve the problem:
Closing the IE and test with the still open FF - No effect. Still same Probs
Open Again the IE and test with IE and FF - No effect
Close the FF and test with the still open IE - No effect
Close FF and IE. Open FF and test with FF - No effect
Open IE And test with IE and FF - No effect
Deleting Cookies in IE and testing with IE and FF - No effect
Deleting Cookies in FF and testing with IE and FF - No effect
Close IE and FF and open FF. Testing in other order (1 test.bewelcome.org, 2 bewelcome.org, 3 alpha.bewelcome.org)

  • Produktion and also test.bewelcome.org works

Open IE and test in old oder - No effect
Close IE and open it again and test in FF order (1 test, 2 prod, 3 alpha) - Produktion and also test.bewelcome.org works
Close FF and IE and open FF to verify the results - No effect. Still same Probs
{...}
I deleted the user from the system and created a other one. Everything works fine. Same with a third testuser on the machine.
{... to make it short...}

I've tested it with different systems in different order with differnet users. Summary of the facts:

  • Login to Production always worked!
  • I only have this Problems on Windows Xp Home Edition with IE 7.0.5730.13 and FF 2.0.0.12
  • I've got the problems with FF and IE (but non-compulsory together)
  • I don't see any system in "working" and "not working".

It's not "cookies"
It's not "temporary files"
It's not "authenticated sessions"
It's not "using direct browsing" (test.bewelcome.org in comparison with http://test.bewelcome.org/bw/member.php?cid=henri)
It's not "using once a logoff"

-> One account (the original) on this machine workes fine (after closing the FF once) and with the first testaccount you get sporadic but not permanent a login (to test and alpha), the other two testaccounts works fine on the very first beginning. (after, of course, I deleted cookies, temporary files and authenticated with the original User on the system)

Guessing:
*A combination of cookies, temporary files and authenticated sessions?
*Operating system?

comment:10 Changed 10 years ago by feuerdaemon

I digget a bit in the open tickets (#281). That really seems to be our problem in this ticket.
I've tested a bit and it's exactly our symptom. It's all about the accepting of the cookies.

We really need a solution for ticket #281!

comment:11 Changed 10 years ago by feuerdaemon

  • Milestone changed from unassigned to Bugs - not sheduled

comment:12 Changed 10 years ago by philipp

  • Milestone changed from Bugs - not sheduled to unassigned

Milestone Bugs - not sheduled deleted

comment:13 Changed 6 years ago by planetcruiser

  • Resolution set to duplicate
  • Status changed from reopened to closed

comment:14 Changed 5 years ago by TimLoal

  • Milestone changed from unassigned to Legacy Resolved
Note: See TracTickets for help on using tickets.