Opened 11 years ago

Closed 7 years ago

Last modified 7 years ago

#484 closed bug (fixed)

Forum Development bugs 2 - Country/Region/City-Tags not working at all

Reported by: micha Owned by: jeanyves
Priority: critical Milestone: 0.6-long
Component: BW Forum Keywords: forum bugs locations country city regions
Cc: jeanyves

Description

Before the modifications by JeanYves?, we could use the locations to order threads. Now that doesn't seem to work anymore. e.g.:

http://test.bewelcome.org/forums/kAS-Asia/cAM-Armenia/a04-Geghark%CA%BCunik%CA%BC/g616874-Astghadzor

Loosing this feature would be a major downgrade in my opinion.

Change History (10)

comment:1 Changed 11 years ago by micha

Any news on this?

comment:2 Changed 11 years ago by philipp

  • Cc jeanyves added
  • Milestone changed from 0.1.4 - improving userinterface for members and volunteers and start work on big 0.2 tasks to 0.5.2-short cleanup and framework

jean-yves, please comment if you have a clue about this

comment:3 Changed 11 years ago by jeanyves

I don't see where it can come from this is probably something to check on the new forum in test

I have'nt change the way forum are connected to location (at least theorically)

comment:4 Changed 10 years ago by micha

  • follow_up changed from none to test
  • freq_reported changed from 1 to >10
  • Milestone changed from 0.5.2-short cleanup and framework to 0.6-long
  • version changed from test to all

That's a problem now laying in production..

comment:5 Changed 9 years ago by globetrotter_tt

  • Owner set to jeanyves

This needs some more attention. There are many posts tagged with Europe->Niue now. http://www.bewelcome.org/forums/kEU-Europe/cNU-Niue/

JeanYves?, could you check this, please?

comment:6 Changed 9 years ago by jeanyves

I have fixed it

It was some quite funny bug:

The code was doing update forums_threads set countrycode='NULL' ...

the consequence, since countrycode is only two chars whas that countrycode what receiving NU which is the code of the country Niue (I don't know where it is ?)

The right code was update forums_threads set countrycode=NULL ... (without the quotes) I have clean the bad values in the database, I just hope nobody intented to post something about this place ...

Please check, test and tellif positive close this trac issue (I have fixed it in Production too)

comment:7 Changed 9 years ago by globetrotter_tt

This is still not working for me. After i have choosen a continent, there should appea another combobox where i can choose a country, region, city.

This does not happen here.

BTW: Niue is small island state (less cititzen than bewelcome has members ;-) in the pacific ocean.

comment:8 Changed 9 years ago by crumbking

  • follow_up changed from test to review code

+1 still does not work. you can just choose a continent.

comment:9 Changed 7 years ago by globetrotter_tt

  • follow_up changed from review code to test on production
  • Resolution set to fixed
  • Status changed from new to closed

It worked for me on production now.

comment:10 Changed 7 years ago by globetrotter_tt

  • follow_up changed from test on production to none
Note: See TracTickets for help on using tickets.