Opened 11 years ago

Closed 6 years ago

#509 closed improve feature (invalid)

Membersearch doesn't work while blocking google(-scripts)

Reported by: midsch Owned by:
Priority: major Milestone: unassigned
Component: BW Search Keywords: search membersearch google block scripts
Cc:

Description

If scripts from google are blocked (here with NoScript? in FF) the search doesn't find anything. The little "loading" is just shown forever. While a search with google maps may need scripts from google, a simple search for usernames in advanced search doesn't need it.

Two tasks:

  • search & find where google script are not necessary
  • message when scripts are blocked/not responding ("You need to allow scripts from google.com to use the search")

In general: It should be possible to search & find without google, maybe not as convenient as our new search.

Change History (10)

comment:1 Changed 11 years ago by micha

  • Milestone changed from 0.1.4 - improving userinterface for members and volunteers and start work on big 0.2 tasks to 0.2 - community

Sorry midsch, I have to move that to 0.2

It's an important feedback and we have to take care of it but I won't be able to handle it now. So let's move it to another release.

comment:2 Changed 9 years ago by crumbking

Could you check back if it still not work?

Maybe we could integrate a link behind the map to the "text view" which shows up when the map is blocked.

comment:3 Changed 9 years ago by midsch

Hmm.

  • No script no search started
  • after allowing BeWelcome-Scripts (but more coming in from BV) i get the loading sign but no result.

(Checked it on test, alpha and production.)

So in short: the problem is still there and the same.

comment:4 Changed 9 years ago by fake51

The search is based on scripts from google - we farm out the complex part of figuring out what the user means to google.

We can possibly implement a fall back that only uses our own scripts (should make that completely non-js). Will take more time and be less useful.

There's simply no way we'll spend time making a js-version that doesn't use the google scripts: it would be a massive waste of time.

comment:5 Changed 9 years ago by midsch

We're not talking about map search. In the initial report quite a while ago, the question was if a " a simple search for usernames in advanced search" really needs google script. If a search for "fake51" is really handled via google, the ticket can be closed. (The search box on the upper right side could be used anyway and accessibility never was an issue for the whole bw-page.)

comment:6 Changed 9 years ago by fake51

Ahhh, I see. Well, if we're dealing with a username search through the advanced search, I can easily route it around the google scripts. Note that this will then only search by the values listed in the advanced search without using any geo stuff - results will be displayed in the same way, though. Is that an acceptable solution?

comment:7 Changed 9 years ago by midsch

Probably it'd make sense to look into the advanced search options to bypass anything that's not related to geo-information. Displaying the info should work (although the map is obviously not visible).

comment:8 Changed 6 years ago by TimLoal

  • Type changed from unknown to improve feature

comment:9 Changed 6 years ago by jsfan

  • Milestone Future deleted

Milestone Future deleted

comment:10 Changed 6 years ago by midsch

  • Milestone set to unassigned
  • Resolution set to invalid
  • Status changed from new to closed

Obsolete through new search (and probably invalide as Google is asked for geonames and search without it won't work anyway).

Note: See TracTickets for help on using tickets.