Opened 11 years ago

Closed 10 years ago

#516 closed bug (fixed)

New search: problems with linebreaks from words in javascript

Reported by: enriqueguillen Owned by: micha
Priority: critical Milestone: 0.5.1-short cleanup I
Component: BW Search Keywords: opera browser search
Cc: guaka

Description

Pietsah has been so kind to report this: "The new search page http://www.bewelcome.org/searchmembers

doesn't work with Opera 9.24 The map doesn't appear, and searchs don't give any results"

Poor pietsah! he is using opera!

Attachments (2)

Opera 9.27 Search Result 2.png (46.4 KB) - added by feuerdaemon 11 years ago.
Opera 9.27 Search Result 2
Opera 9.27 Search Result.png (187.4 KB) - added by feuerdaemon 11 years ago.
Opera 9.27 Search Result

Download all attachments as: .zip

Change History (19)

comment:1 Changed 11 years ago by midsch

  • Keywords search added
  • Milestone changed from Bugs - not sheduled to 0.1.4 - improving userinterface for members and volunteers and start work on big 0.2 tasks
  • Summary changed from problems with opera browser to New search: problems with opera browser

Just to be sure: could someone with Opera reproduce it while checking if scripts from google are NOT blocked? (see http://www.bevolunteer.org/trac/ticket/509 )

comment:2 Changed 11 years ago by feuerdaemon

The Member Search works fine on Kubuntu 7.10 with Opera 9.27 - I can not reproduce that
The only way it does not work, is in the German Translation, like in ticket #492

comment:3 Changed 11 years ago by midsch

firedaemon: If you see the searchmembersScriptInfoText it's a sign for blocked scripts.

comment:4 Changed 11 years ago by guaka

  • Cc guaka added
  • Owner set to lemon-head

lemon-head, I know you're an Opera fan, so I try assigning it to you. Feel free to unassign.

comment:5 Changed 11 years ago by lemon-head

ok, some tests.

Testing on Version 9.26, Build 8835.

  • german search is totally broken -> the map is white!
  • english or french does work, but the left sidebar is squeezed! (only half of the width it should have)
  • don't remember performance of the map.

Testing with Version 9.27, Build 8841

  • german is totally broken, map is white
  • english or french does work, but sidebar is squeezed
  • performance of the map is much improved, compared to the below version.

Testing with Version 9.50 beta, Build 9789

  • german is broken, white map.
  • english or french work, and don't have the layout problems mentioned above.
  • map scrolling and zooming is painfully slow, compared to Firefox.

Testing with Version 9.50 beta, Build 9903

  • german is broken, white map.
  • english or french have no problems
  • performance is much much better!

Testing with Firefox

  • german is broken
  • the rest does work.

I think this must be a translation problem! Some words in the german translation which break the javascript.

comment:6 Changed 11 years ago by lemon-head

Fixed for german.

The problem is, that some parts in searchmembers can't handle linebreaks in translated text. I removed all the linebreaks from the german translations.

We still have the same problem in spanish translation. I think it's better to fix the code, not the translations.

comment:7 Changed 11 years ago by lemon-head

  • Summary changed from New search: problems with opera browser to New search: problems with linebreaks from words in javascript

comment:8 Changed 11 years ago by lemon-head

  • Owner changed from lemon-head to micha

I pass it to Micha, who agreed to work on it :)

comment:9 Changed 11 years ago by micha

  • follow_up changed from none to test
  • show_on_bw changed from 0 to 1
  • Status changed from new to assigned

Committed a fix in [4559]. Please test to move it on to alpha fast.

comment:10 Changed 11 years ago by lemon-head

  • Priority changed from major to critical

Please, speed up with this!!!

comment:11 Changed 11 years ago by feuerdaemon

Map is shown now and the search works fine with Kubuntu 7.10 and Opera 9.27

but the layout it still squeezed. -> see added pictures

Changed 11 years ago by feuerdaemon

Opera 9.27 Search Result 2

Changed 11 years ago by feuerdaemon

Opera 9.27 Search Result

comment:12 Changed 11 years ago by micha

  • follow_up changed from test to move to alpha

Thanks for the feedback about the CSS-bugs, feuerdaemon but it's the wrong ticket for this. The javascript problems seem to be fixed at least.

comment:13 Changed 11 years ago by micha

  • follow_up changed from move to alpha to test on alpha

moved to alpha in r4603

comment:14 Changed 11 years ago by philipp

  • Milestone changed from 0.1.4 - improving userinterface for members and volunteers and start work on big 0.2 tasks to 0.5.1-short cleanup I

comment:15 Changed 10 years ago by feuerdaemon

Works fine on WinXP with Opera 9.27.

comment:16 Changed 10 years ago by feuerdaemon

  • follow_up changed from test on alpha to release

comment:17 Changed 10 years ago by micha

  • follow_up changed from release to none
  • Resolution set to fixed
  • Status changed from assigned to closed

moved to production in r4647

Note: See TracTickets for help on using tickets.