Opened 11 years ago

Closed 6 years ago

Last modified 6 years ago

#525 closed bug (invalid)

sending a post on forums creates an SQL error.

Reported by: lemon-head Owned by:
Priority: major Milestone: Legacy Resolved
Component: BW Database Keywords:
Cc:

Description

I tried to submit a reply on http://test.bewelcome.org/forums/s36-link-testing, and got an SQL error (two times)

I think the important part is this one,
Duplicate entry '250' for key 1

<exception>
<code>1000</code>
<message>MySQL error!</message>
−
	<file>
/var/www/test_html/lib/db/db_statement_mysql.lib.php
</file>
<line>291</line>
−
	<info>
Statement: insert into forum_trads(TableColumn,IdRecord,IdLanguage,IdOwner,IdTrad,IdTranslator,Sentence,created) Values('forums_posts.IdContent',132,0,1,229,1,"Especially, the tinymce WYSIWYG engine doesn\'t show up anymore.<br/><br/>&#13;\nI don\'t like this thing anyway, but a box without any formatting help is even worse!<br/><br/>&#13;\nAnd yes, the links don\'t work.",now())
</info>
<info>1062</info>
<info>Duplicate entry '250' for key 1</info>
−
	<trace>
−
	<event stackno="0">
<file>/var/www/test_html/lib/db/db_mysql.lib.php</file>
<line>299</line>
<class type="->">PDBStatement_mysql</class>
<function>query</function>
−
	<args>
−
	<arg>
insert into forum_trads(TableColumn,IdRecord,IdLanguage,IdOwner,IdTrad,IdTranslator,Sentence,created) Values('forums_posts.IdContent',132,0,1,229,1,"Especially, the tinymce WYSIWYG engine doesn\'t show up anymore.
<br/>
<br/>

\nI don\'t like this thing anyway, but a box without any formatting help is even worse!
<br/>
<br/>

\nAnd yes, the links don\'t work.",now())
</arg>
</args>
</event>
−
	<event stackno="1">
<file>/var/www/test_html/build/forums/forums.model.php</file>
<line>117</line>
<class type="->">PDB_mysql</class>
<function>query</function>
−
	<args>
−
	<arg>
insert into forum_trads(TableColumn,IdRecord,IdLanguage,IdOwner,IdTrad,IdTranslator,Sentence,created) Values('forums_posts.IdContent',132,0,1,229,1,"Especially, the tinymce WYSIWYG engine doesn\'t show up anymore.
<br/>
<br/>

\nI don\'t like this thing anyway, but a box without any formatting help is even worse!
<br/>
<br/>

\nAnd yes, the links don\'t work.",now())
</arg>
</args>
</event>
−
	<event stackno="2">
<file>/var/www/test_html/build/forums/forums.model.php</file>
<line>1154</line>
<class type="->">Forums</class>
<function>InsertInFTrad</function>
−
	<args>
−
	<arg>
Especially, the tinymce WYSIWYG engine doesn\'t show up anymore.
<br/>
<br/>

\nI don\'t like this thing anyway, but a box without any formatting help is even worse!
<br/>
<br/>

\nAnd yes, the links don\'t work.
</arg>
<arg>forums_posts.IdContent</arg>
<arg>132</arg>
</args>
</event>
−
	<event stackno="3">
<file>/var/www/test_html/build/forums/forums.model.php</file>
<line>863</line>
<class type="->">Forums</class>
<function>replyTopic</function>
−
	<args>
<arg>Array</arg>
</args>
</event>
−
	<event stackno="4">
<file>/var/www/test_html/build/forums/forums.ctrl.php</file>
<line>297</line>
<class type="->">Forums</class>
<function>replyProcess</function>
<args/>
</event>
−
	<event stackno="5">
<class type="->">ForumsController</class>
<function>replyProcess</function>
<args/>
</event>
−
	<event stackno="6">
<file>/var/www/test_html/lib/handler/posthandler.lib.php</file>
<line>101</line>
<function>call_user_func</function>
−
	<args>
<arg>Array</arg>
</args>
</event>
−
	<event stackno="7">
<file>/var/www/test_html/lib/handler/posthandler.lib.php</file>
<line>51</line>
<class type="->">PPostHandler</class>
<function>save</function>
<args/>
</event>
−
	<event stackno="8">
−
	<file>
/var/www/test_html/tools/routing/roxfrontrouter.class.php
</file>
<line>103</line>
<class type="::">PPostHandler</class>
<function>get</function>
<args/>
</event>
−
	<event stackno="9">
−
	<file>
/var/www/test_html/tools/routing/roxfrontrouter.class.php
</file>
<line>32</line>
<class type="->">RoxFrontRouter</class>
<function>traditionalPostHandling</function>
<args/>
</event>
−
	<event stackno="10">
<file>/var/www/test_html/roxlauncher/roxlauncher.php</file>
<line>303</line>
<class type="->">RoxFrontRouter</class>
<function>route</function>
−
	<args>
<arg>Object id #59</arg>
</args>
</event>
−
	<event stackno="11">
<file>/var/www/test_html/roxlauncher/ptlauncher.php</file>
<line>45</line>
<class type="->">RoxLauncher</class>
<function>chooseAndRunApplication</function>
<args/>
</event>
−
	<event stackno="12">
<file>/var/www/test_html/htdocs/index.php</file>
<line>62</line>
<class type="->">PTLauncher</class>
<function>launch</function>
<args/>
</event>
</trace>
</exception>

Change History (5)

comment:1 Changed 11 years ago by lemon-head

  • Component changed from unknown to BW Database

comment:2 Changed 11 years ago by lemon-head

And why on earth do we send the sidTB information as a GET parameter in the redirect ???

comment:3 Changed 11 years ago by lemon-head

  • version set to test

comment:4 Changed 6 years ago by TimLoal

  • Resolution set to invalid
  • Status changed from new to closed

Resolving due to age and lack of interest, in recent years.

Please create a new ticket and link to this historical ticket, if you discover bW.org has continuing issues with this issue.

bW Housekeeping

LnP

comment:5 Changed 6 years ago by TimLoal

  • Milestone changed from unassigned to Legacy Resolved
Note: See TracTickets for help on using tickets.