Opened 11 years ago

Closed 10 years ago

#529 closed bug (fixed)

membersonline counter shows "0".

Reported by: lemon-head Owned by: lemon-head
Priority: major Milestone: Rox Framework
Component: FrameWork Keywords:
Cc: micha, jeanyves, lemon-head, guaka

Description

This is a bug caused by the new architecture. I would like to fix it, but membersonline counter is really a complex procedure. (at least, it's coded in a complex way).

What needs to happen:

  • with every request, we have to update the membersonline and guestsonline statistics. (in the database)
  • the number has to be made accessible for the page, to show it in the menu. Currently we have $_SESSIONWhoIsOnlineCount? for this purpose. (don't ask me why it's in the session).
  • the number is then read and displayed in PageWithRoxLayout::topnav(). If the session value is not set at that time, a "0" is shown instead (before that it was "-1").

The problem right now is, that the session variable is not set, even though it should.


We should fix this, before the stuff in "roxlauncher" and "tools" goes to alpha and production!

Change History (9)

comment:1 Changed 11 years ago by lemon-head

  • Component changed from unknown to FrameWork
  • Milestone changed from unassigned to Rox Framework

comment:2 Changed 11 years ago by jeanyves

The update of membersonline / guestonline is not a big big deal, of course it will be better if it was some memory shared table which php could access. Note that on the server these table are memory table (but a real memory shared area will be far more efficient).

The $_SESSIONWhoIsOnlineCount? is not something brillant, I think I did it because I find it easy to have it as a global variable, this was not the most logical idea it will certainly fit better in some Page->WhoIsonlineCount? or Rox->WhoIsOnlineCount? or even better Rox->GetWhoIsOnlineCount?() ...

If you could find a way to fix the -1

One last thing (tricky one) I already have remove the $_POST[password] from the URL momentaneous log for guest, I recently realized that $_POST[Message] and may be some other should also be removed (I know there is a disputation about this extra whosionline capability, but it is the thing which helped me to realize what was the recent login problem with the user table when I saw some guest attempting (and failing) continuously to login, similar things can happen again).

comment:3 Changed 11 years ago by lemon-head

About $_POST (off-topic, actually)

With the new posthandler in the Rox Framework, it will be the default to delete ALL $_POST values before the application controller is called, and pass them on as local variables instead.

I don't know if the log happens before that?

comment:4 Changed 11 years ago by lemon-head

  • follow_up changed from none to test

[4607] should do the trick.

comment:5 Changed 11 years ago by lemon-head

  • Owner set to lemon-head
  • Status changed from new to assigned

comment:6 Changed 11 years ago by micha

  • follow_up changed from test to move to alpha

Seems to work well!

comment:7 Changed 10 years ago by philipp

  • Cc micha jeanyves lemon-head guaka added

please move to alpha

comment:8 Changed 10 years ago by micha

repaired membersonline in r5341. Still awating the move from Andreas changes to alpha

comment:9 Changed 10 years ago by micha

  • follow_up changed from move to alpha to none
  • Resolution set to fixed
  • Status changed from assigned to closed

moved to production already in r5261. Closing ticket.

Note: See TracTickets for help on using tickets.