Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#611 closed new feature (fixed)

Add search functionality on the BW forum

Reported by: crumbking Owned by:
Priority: major Milestone: 0.6-long
Component: BW Forum Keywords:
Cc:

Description

As BW growth the threads in the forum grow as well.
Please add a search function with following:

*form with search button on the forum overview
*new site with a list of search results

The search results list should have:

  • thread
  • post(s) extract with the matching search words
  • sorted by relevance (%) (dependence on search words)

Change History (6)

comment:1 Changed 10 years ago by philipp

agree. maybe we should make a custom google search available for the time being?

as an example how this search would perform you can try it out at our volunteer search https://alpha.bewelcome.org/volunteer/search . Just enter a search term, submit and then refine by "BW forum"

Of course it will miss the most recent posts but it would be extremely easy to implement (10minutes).

comment:2 Changed 10 years ago by crumbking

Seems to work. For a temporary solution it could work.

Could you implement it in a way that you dont need to refine for BW forum? (like it is now in vol section)

Could you change the colors of the links to bw orange, same for fonts, font size (you know that it looks more like BW)

Could you remove the drop down "browse all categories" in BW forum as this function is a duplicate of what you get if you simply click on the links in "browse the forum by category" (in overview) and then add the search field there?

I never used this "drop down" and I think it's useless (maybe we should discuss this?)

comment:3 Changed 10 years ago by philipp

  • follow_up changed from none to test on alpha
  • version set to alpha

available on alpha

comment:4 Changed 10 years ago by crumbking

  • follow_up changed from test on alpha to release

Great! It works fine with FF3/Mac.

Just some small things:

  • could you make the search field half of the size than it is actually now
  • could you change the result links color from grey (I mean the titles of the result entries) to bw orange and visited links to grey
  • "Rechercher sur le Forum" this is what I get above the search field, shouldn't it be in english while surfing the site in english?

anyway just small things (question of taste...)

works fine ...

comment:5 Changed 10 years ago by philipp

  • Resolution set to fixed
  • Status changed from new to closed

I think I can't do anything about the size of the field but will definitely change the colors - it was just a quick guess what could look BW like (links orange, at least in wikis title grey) I have no clue who put the french translation in there but of course it should be english.

the biggest drawback is that you get multiple hits for stuff that has serveral tags - so we just have to code our own search at some point.

comment:6 Changed 10 years ago by philipp

  • follow_up changed from release to none
Note: See TracTickets for help on using tickets.