Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#647 closed bug (fixed)

Killing query in rox.model.php getAllCityLatLong() function

Reported by: jeanyves Owned by:
Priority: critical Milestone: Legacy Resolved
Component: BW Geo Keywords: performance
Cc:

Description

For information : I just found a killing query in rox.model, it is the one which does : [18:12:28] Hégron Jean-Yves a dit : SELECT latitude,longitude

FROM members, memberspublicprofiles, cities WHERE cities.id=members.IdCity? AND members.Status=\'Active\' GROUP BY members.id desc limit 20

[18:12:35] Hégron Jean-Yves a dit : I am going to change it for : [18:12:55] Hégron Jean-Yves a dit : SELECT latitude,longitude

FROM members, cities WHERE cities.id=members.IdCity? AND members.Status='Active' ORDER BY members.id desc limit 20

[18:13:34] Hégron Jean-Yves a dit : the problem is that it uselessly browse the whole memberspublicprofile and probably the whole members table [18:16:02] Hégron Jean-Yves a dit : ah, but it looks it was allready fixed in trunk ! [18:16:14] Hégron Jean-Yves a dit : good, but this is most a problem in production ! [18:23:36] Hégron Jean-Yves a dit : hmm, in test the query will retrieve the full members list (rox.model.php getAllCityLatLong() function), please, try to reconsider it

Change History (3)

comment:1 Changed 10 years ago by jeanyves

I have fixed it in production,

but something is to be done in test, please someone : react, thanks !

comment:2 Changed 10 years ago by jeanyves

  • Resolution set to fixed
  • Status changed from new to closed

comment:3 Changed 6 years ago by TimLoal

  • Component changed from BW General to BW Geo
  • Milestone changed from unassigned to Legacy Resolved
  • Type changed from unknown to bug
Note: See TracTickets for help on using tickets.