Opened 10 years ago

Closed 9 years ago

Last modified 6 years ago

#724 closed bug (fixed)

MySQL error on linkpage to my forum posts

Reported by: midsch Owned by: jeanyves
Priority: major Milestone: Legacy Resolved
Component: BW Forum Keywords:
Cc: micha@…

Description

From https://alpha.bewelcome.org/bw/member.php?cid=USERNAME the link to "my forum posts" - https://alpha.bewelcome.org/forums/member/USERNAME - ends up in the following error message:

MySQL error!

PException
code: 	1000
message: 	MySQL error!
file: 	/home/bwrox/alpha.bewelcome.org/lib/db/db_statement_mysql.lib.php
line: 	291

info[0]: Statement: SELECT `postid`, UNIX_TIMESTAMP(`create_time`) AS `posttime`, `message`, `OwnerCanStillEdit`,`IdContent`, `forums_threads`.`threadid`, `forums_threads`.`title`, `forums_threads`.`IdTitle`,`forums_threads`.`IdGroup`, `user`.`id` AS `user_id`,`IdWriter`, `members`.`Username` AS `user_handle`, `groups`.`Name` AS `GroupName`, `geonames_cache`.`fk_countrycode` FROM `forums_posts`,`members`,`forums_threads`,`user` LEFT JOIN `groups` ON (`forums_threads`.`IdGroup` = `groups`.`id`) LEFT JOIN `geonames_cache` ON (`user`.`location` = `geonames_cache`.`geonameid`) WHERE `forums_posts`.`IdWriter` = 1066 AND `forums_posts`.`IdWriter` = `members`.`id` AND `user`.`handle` = `members`.`Username` AND `forums_posts`.`threadid` = `forums_threads`.`threadid` AND `forums_posts`.`authorid` = `user`.`id` ORDER BY `posttime` DESC
info[1]: 1054
info[2]: Unknown column 'forums_threads.IdGroup' in 'on clause'
PDBStatement_mysql::query( string(847) = "SELECT `postid`, "

SELECT    `postid`, UNIX_TIMESTAMP(`create_time`) AS `posttime`,  `message`,
    `OwnerCanStillEdit`,`IdContent`,  `forums_threads`.`threadid`,   `forums_threads`.`title`,
    `forums_threads`.`IdTitle`,`forums_threads`.`IdGroup`,   `user`.`id` AS `user_id`,`IdWriter`,   `members`.`Username` AS `user_handle`, `groups`.`Name` AS `GroupName`,
    `geonames_cache`.`fk_countrycode` FROM `forums_posts`,`members`,`forums_threads`,`user`
LEFT JOIN `groups` ON (`forums_threads`.`IdGroup` = `groups`.`id`)
LEFT JOIN `geonames_cache` ON (`user`.`location` = `geonames_cache`.`geonameid`)
WHERE `forums_posts`.`IdWriter` = 1066 AND `forums_posts`.`IdWriter` = `members`.`id` 
AND `user`.`handle` = `members`.`Username` AND `forums_posts`.`threadid` = `forums_threads`.`threadid` 
AND `forums_posts`.`authorid` = `user`.`id` 
ORDER BY `posttime` DESC    

)
/home/bwrox/alpha.bewelcome.org/lib/db/db_mysql.lib.php (line 299)
PDB_mysql::query( string(847) = "SELECT `postid`, "

SELECT    `postid`, UNIX_TIMESTAMP(`create_time`) AS `posttime`,  `message`,
    `OwnerCanStillEdit`,`IdContent`,  `forums_threads`.`threadid`,   `forums_threads`.`title`,
    `forums_threads`.`IdTitle`,`forums_threads`.`IdGroup`,   `user`.`id` AS `user_id`,`IdWriter`,   `members`.`Username` AS `user_handle`, `groups`.`Name` AS `GroupName`,
    `geonames_cache`.`fk_countrycode` FROM `forums_posts`,`members`,`forums_threads`,`user`
LEFT JOIN `groups` ON (`forums_threads`.`IdGroup` = `groups`.`id`)
LEFT JOIN `geonames_cache` ON (`user`.`location` = `geonames_cache`.`geonameid`)
WHERE `forums_posts`.`IdWriter` = 1066 AND `forums_posts`.`IdWriter` = `members`.`id` 
AND `user`.`handle` = `members`.`Username` AND `forums_posts`.`threadid` = `forums_threads`.`threadid` 
AND `forums_posts`.`authorid` = `user`.`id` 
ORDER BY `posttime` DESC    

)
/home/bwrox/alpha.bewelcome.org/build/forums/forums.model.php (line 2151)
Forums::searchUserposts( string(6) = "USERNAME"

USERNAME

)
/home/bwrox/alpha.bewelcome.org/build/forums/forums.ctrl.php (line 303)
ForumsController::searchUserposts( string(6) = "USERNAME"

USERNAME

)
/home/bwrox/alpha.bewelcome.org/build/forums/forums.ctrl.php (line 217)
ForumsController::index( stdClass object

stdClass Object
(
    [request_uri] => /forums/member/USERNAME
    [request] => Array
        (
            [0] => forums
            [1] => member
            [2] => USERNAME
        )

    [req] => forums/member/USERNAME
    [get] => Array
        (
        )

    [post] => Array
        (
        )

    [get_or_post] => Array
        (
        )

    [post_or_get] => Array
        (
        )

)

)
/home/bwrox/alpha.bewelcome.org/tools/routing/roxfrontrouter.class.php (line 258)
RoxFrontRouter::runControllerIndexMethod( string(16) = "ForumsController"

ForumsController

, stdClass object

stdClass Object
(
    [request_uri] => /forums/member/USERNAME
    [request] => Array
        (
            [0] => forums
            [1] => member
            [2] => USERNAME
        )

    [req] => forums/member/USERNAME
    [get] => Array
        (
        )

    [post] => Array
        (
        )

    [get_or_post] => Array
        (
        )

    [post_or_get] => Array
        (
        )

)

)
/home/bwrox/alpha.bewelcome.org/tools/routing/roxfrontrouter.class.php (line 146)
RoxFrontRouter::route_normal( stdClass object

stdClass Object
(
    [request_uri] => /forums/member/USERNAME
    [request] => Array
        (
            [0] => forums
            [1] => member
            [2] => USERNAME
        )

    [req] => forums/member/USERNAME
    [get] => Array
        (
        )

    [post] => Array
        (
        )

    [get_or_post] => Array
        (
        )

    [post_or_get] => Array
        (
        )

)

)
/home/bwrox/alpha.bewelcome.org/tools/routing/roxfrontrouter.class.php (line 24)
RoxFrontRouter::route( stdClass object

stdClass Object
(
    [request_uri] => /forums/member/USERNAME
    [request] => Array
        (
            [0] => forums
            [1] => member
            [2] => USERNAME
        )

    [req] => forums/member/USERNAME
    [get] => Array
        (
        )

    [post] => Array
        (
        )

    [get_or_post] => Array
        (
        )

    [post_or_get] => Array
        (
        )

)

)
/home/bwrox/alpha.bewelcome.org/roxlauncher/roxlauncher.php (line 61)
RoxLauncher::chooseAndRunApplication( EnvironmentExplorer object

EnvironmentExplorer Object
(
    [classes] => Array
        (
        )

)

)
/home/bwrox/alpha.bewelcome.org/roxlauncher/roxlauncher.php (line 22)
RoxLauncher::launch()
/home/bwrox/alpha.bewelcome.org/htdocs/index.php (line 62)

Change History (6)

comment:1 Changed 10 years ago by midsch

  • Component changed from BV Forum to BW Forum

comment:2 Changed 9 years ago by micha

  • Cc micha@… added
  • freq_reported changed from 1 to >5
  • Owner set to jeanyves
  • version changed from alpha to all

comment:3 Changed 9 years ago by jeanyves

Wait for next switch from the imporved forum visibility version in Alpha, I hope this will solve this one

comment:4 Changed 9 years ago by globetrotter_tt

  • follow_up changed from review code to test on production
  • Resolution set to fixed
  • Status changed from new to closed

I could not reproduce this anymore.

comment:5 Changed 8 years ago by globetrotter_tt

  • follow_up changed from test on production to none

comment:6 Changed 6 years ago by TimLoal

  • Milestone changed from unassigned to Legacy Resolved
Note: See TracTickets for help on using tickets.