Opened 10 years ago

Closed 8 years ago

#96 closed improve feature (fixed)

edit post - mark post as changed

Reported by: philipp Owned by: jeanyves
Priority: major Milestone: 0.5.2
Component: BW Forum Keywords:
Cc:

Description

when a user or moderator edits a post a note "this post has been edited by username/moderator on date" has to be displayed along with the post.

Change History (8)

comment:1 Changed 10 years ago by jeanyves

  • follow_up set to none
  • freq_reported set to 1
  • Owner set to jeanyves
  • show_on_bw set to 0

Definitively this is needed, in addition I want to keep historic of previous version and a way to see them (and who has edited)

comment:2 Changed 10 years ago by philipp

Personally I disagree with keeping any logs of the previous version (and old content, deleted by the member in general). If I decide to change a post this is by purpos and I don't want some volunteers to dig in the old stuff I retracted. To discuss this I started a thread on the forum (limited access): http://www.bevolunteer.org/forum/index.php?topic=1425.0

comment:3 Changed 10 years ago by philipp

  • Milestone changed from 0.1.4 - improving userinterface for members and volunteers and start work on big 0.2 tasks to 0.5.2-short cleanup and framework

there is still no real decision on how to handle post edits. however it should be possible to take a decision as everything has been said by now - after this implementation should not be too difficult

comment:4 Changed 9 years ago by micha

status on this one?

comment:5 Changed 9 years ago by jeanyves

For now there is an historic, it is well protected (I mean, no risk that the previous values goes on line).

I am still pro keeping it, especially while forum is not fully stable. I woudl say, raise the question again in one year (and we will then probably have enough feedback from moderators to see if despite it is useful for debugging, it has some use for moderators)

comment:6 Changed 9 years ago by crumbking

Okay, only question left for closing the ticket : Does the member see that a change is made by a moderator? Because I guess the member isn't able to see the history.

Something like automatic like: "this post has been edited by username/moderator on date" ?

comment:7 Changed 8 years ago by jeanyves

I just figure that they are some cases of moderator edit which are not visible for the member, in case the moderator update the content of the text, there is a mark.
(@Manuel for example look at http://www.bewelcome.org/forums/s708/#post4092 I replaced your single jup with a jup jup

But if the moderator action is just allowing again the post for edit, adjusting the tags, changing its group, this si not automaticallys displayed in the post.

The habbit on forums is that, if he thinks it is needed, the moderator usually add a [edited by XXXX for reason] manually, depending on its own decision.

I personnaly prefere that we automatically displays changes mde by other people, it can avoid problem, where is the limit ? Group managment can in the long run create many many [edited by moderator] (in case we need to merge some redundant groups)

The problem is to avoid to overload the layout with too many infomation.

May be what is needed, to be fair and transparent, is to provide a way for a member to be informed of all teh things moderators did on one of his own post.
Using the logs it should be very possible, but a small problem is that it cannot be put online because it will need hight ressource.
Anyway, if someone ask for it, it is possible to retrieve all the logs for moderator action regarding one of his post.

So, my conclusion, considering the current situation:

  • if a moderator changes a text in a post, everybody can see it (and the moderator has no control about this information)
  • if the moderator changes some property (Group, Tag, expiration date ...), he can had a note betwee bracket in the test of the post, but this is not mandatory
  • In case we have any doubt about moderators action about a given post, it should not be too difficult to make a report for a given post about moderators action based on the BW log

comment:8 Changed 8 years ago by crumbking

  • Resolution set to fixed
  • Status changed from new to closed

Thanks jeanyves for the explanation. This is enough for this ticket and I will close it.

If in future much more control of the moderator(s) is needed than we can open a new ticket.

fixed

Note: See TracTickets for help on using tickets.